Информатика, вопрос задал Kpuc , 10 лет назад

составьте программу к задаче:"Сумма 10000 рублей положена в сберегательный банк, при этом прирост составляет 5% годовых. Составьте алгоритм, определяющий, через какой промежуток времени первоначальная сумма увеличится в два раза."
помогите пожалуйста 

Ответы на вопрос

Ответил Programust
0
Pascal
var a,x,l:real;
begin
a:=10000;
x:=10000/100*5;
l:=0;
while a<=20000 do
begin
a:=x+a;
l:=l+1;
end;
write(l,' год');
end.
Ответил Spikespiegele
0
начало S_{1}=10000; k=1,05; S_{2}=S_{1}; t=0,
если не  S_{2} >= 2*S_{1},
тогда  t++;  S_{2} = k*S_{2};
вернуться к условию,
иначе
вывод t конец 

Новые вопросы