Информатика, вопрос задал Maxero , 7 лет назад

Составьте программу, используя подпрограмму (процедуру или функцию). В одномерном массиве случайных чисел MAS [1..15] вычислить произведение элементов, кратных 3.
Это все нужно в Паскале.

Ответы на вопрос

Ответил supersuperkirip54irs
0

var mas:array [1..15] of integer;


i:integer;


k:biginteger;


function f(mas:integer):boolean;


begin


if (mas mod 3=0) then f:=True;


if (mas mod 3<>0) then f:=False;


end;


BEGIN


k:=1;


for i:=1 to 15 do begin


mas[i]:=random(100)+1;


write(mas[i],' ');


if (f(mas[i])=True) then k:=k*mas[i];


end;


writeln();


if (k=1) then writeln('Нет элементов, кратных 3') else


writeln(k);


end.

Ответил Maxero
0
Благодарю
Новые вопросы