Информатика, вопрос задал Адиль19 , 8 лет назад

Составьте программу для вычисления значений следующих функций:
помогите пожалуйста хотя бы только а)

Приложения:

Ответы на вопрос

Ответил snapdragon537
0

1)#include <iostream>

using namespace std;

int main()

{

int x;//вводит пользователь

int y;//фунцыя

cout << "Please enter x > ";

cin >> x;

if (x <= -2 & x <= 2)//если -2<=x<=2

 y = x * x;

else

 y = 4;

cout << "From x : " << x << "; Y = " << y << endl;

system("pause");

return 0;

}

2)

#include <iostream>

using namespace std;

int main()

{

int x;//вводит пользователь

int y;//функцыя

cout << "Enter x > ";

cin >> x;

if (x < 2)

 y = (1 + cos(2 * x)) / 2;//формула cos^2 X;

else

 y = 1 + (1 - cos(2 * x)) / 2;//формула sin^2 X;

cout << "Your function from X : " << x << "; Y = " << y << endl;

system("pause");

return 0;

}

Возможно запорол с формулами, перепроверь наверняка.

Приложения:
Ответил Адиль19
0
спасибо
Новые вопросы