Информатика, вопрос задал ryxberlin , 8 лет назад

Составьте программу для вычисления выражения в Паскале
x=sin 2y+cos 2z/корень из sin y*cos z

Ответы на вопрос

Ответил Аноним
0
Поскольку автор вопроса не откликается, а представленное в вопросе выражение может интерпретироваться по-разному, было принято решение записать формулу "как есть", т.е. в предположении, что она записана верно и скобки в ней не были нужны.

displaystyle x=sin 2y+ frac{cos 2z}{sqrt{sin y}}cos z

PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (y,z):=ReadReal2('Введите y и z:');
  var x:=Sin(2*y)+Cos(2*z)/Sqrt(Sin(y))*Coz);
  Writeln('x=',x)
end.
Новые вопросы