Информатика, вопрос задал AndreyNikitin7 , 8 лет назад

Составьте программу для вычисления суммы цифр заданного трехзначного числа.
На паскале

Ответы на вопрос

Ответил Аноним
0
var
  n:integer;
 
begin
  Write('n = '); Read(n);
  Writeln(n div 100+(n div 10) mod 10+n mod 10)
end.

Пояснения.
n div 100 дает первую цифру: результат деления нацело числа на 100.
(n div 10) mod 10 дает вторую цифру: вычисляется результат деления нацело числа на 10 и от него берется остаток деления на 10.
n mod 10 дает третью цифру: остаток целочисленного деления числа на 10.
Новые вопросы