Информатика, вопрос задал elisbatori , 2 года назад

составьте программу для вычисления площади четырехугольника с координатами вершин (x1,y1) , (x2,y2), (x3,y3), (x4,y4) площадь четырехугольника вычислите как сумму площадей двух треугольников.
Pascal ABC

Ответы на вопрос

Ответил A1dar
4
var x1, y1, x2, y2, x3, y3, x4, y4: real;
begin
  read(x1, y1, x2, y2, x3, y3, x4, y4);
  write(abs((x1 - x2) * (y3 - y2) - (y1 - y2) * (x3 - x2)))
end.

A1dar: Наверху решение для прямоугольника, а вот для произвольного четырехугольника:
var
  x1, y1, x2, y2, x3, y3, x4, y4: real;
    
function Square_Of_Triangle(ax, ay, bx, by, cx, cy: real): real := abs((ax - bx) * (cy - by) - (ay - by) * (cx - bx)) / 2;
  
begin
  read(x1, y1, x2, y2, x3, y3, x4, y4);
  write(Square_Of_Triangle(x1, y1, x2, y2, x3, y3) + Square_Of_Triangle(x2, y2, x3, y3, x4, y4));
end.
Новые вопросы