Составьте программу. Для вводимых с клавиатуры чисел определить количество положительных. ввод чисел прекращается, когда пользователь вводит 0.
Ответы на вопрос
Ответил petyaGavrikov
0
var a,k:integer;
begin
writeln('Вводите числа. Конец ввода - 0');
k:=0;
readln(a);
while a<>0 do
begin
if a>0 then k:=k+1;
readln(a);
end;
writeln('k = ',k);
end.
Пример:
Вводите числа. Конец ввода - 0
8
-4
5
-2
3
-7
0
k = 3
begin
writeln('Вводите числа. Конец ввода - 0');
k:=0;
readln(a);
while a<>0 do
begin
if a>0 then k:=k+1;
readln(a);
end;
writeln('k = ',k);
end.
Пример:
Вводите числа. Конец ввода - 0
8
-4
5
-2
3
-7
0
k = 3
Новые вопросы