Составьте программу для решения одной из следующих задач, которая запрашивает значение элементов одномерного числового массива А и подсчета суммы элементов массива, меньших своего номера.
Ответы на вопрос
Ответил Gleb1Kosyrev
0
//Pascal ABC.NET v3.1 сборка 1219
Const
n=5;
Var
a:array[1..n] of integer;
i,s:integer;
begin
for i:=1 to n do
begin
readln(a[i]);
if a[i]<i then s:=s+a[i];
end;
writeln(s);
end.
Пример ввода:
2
2
1
1
2
Пример вывода:
4
Const
n=5;
Var
a:array[1..n] of integer;
i,s:integer;
begin
for i:=1 to n do
begin
readln(a[i]);
if a[i]<i then s:=s+a[i];
end;
writeln(s);
end.
Пример ввода:
2
2
1
1
2
Пример вывода:
4
Новые вопросы
Английский язык,
2 года назад
Литература,
2 года назад
Алгебра,
9 лет назад
Химия,
9 лет назад
Информатика,
9 лет назад