Информатика, вопрос задал arseniy7159 , 2 года назад

Составьте программу для нахождения суммы, разности, произведения, частного двух (необязательно целых) чисел.
Предусмотрите чтобы в случае деления на 0, выводилось сообщение "нельзя поделить на 0"

без паскаля если можно, если нельзя сорян, я не шарю​

Ответы на вопрос

Ответил MA3EIN
0

#include <iostream>

#include <cstdlib> // для system

using namespace std;

int main()

{

setlocale(LC_ALL, "Russian");

double a,b,sum,razn,del,proizv;

cout << " Input a,b ";

cin >> a >> b;

sum = a + b;

razn = a - b;

del = a / b;

proizv = a * b;

cout << a << " + " << b << " = " << sum << endl;

cout << a << " - " << b << " = " << razn << endl;

cout << a << " * " << b << " = " << proizv << endl;

try

{

if (b == 0)

{

throw 123;

}

cout << a << " / " << b << " = " << a / b << endl;

}

catch(int i)

{

cout << a << " / " << b << " = " << "Ошибка №" << i << " - на 0 делить нельзя!!!!" << endl;

}

}

Новые вопросы