Информатика, вопрос задал tatyanastudenko , 9 лет назад

Составьте программу для нахождения минимального элемента массива Х, состоя-
щего из 6 элементов, значения которых рассчитываются по формуле
X=(sini-1)/2cosi+1
Язык Турбо Паскаль

Ответы на вопрос

Ответил petyaGavrikov
0
const n=6;
var x:array[1..n] of real;
min:real; i:integer;
begin
for i:=1 to n do
 x[i]:=(sin(i)-1)/(2*cos(i))+1;
min:=x[1];
for i:=2 to n do
 if x[i]<min then min:=x[i];
writeln('min=',min:5:3);
end.

Новые вопросы