составьте программу для чтения отрывка из текста.Переключение его на Перевертыш и передача его на печать в том же варианте. Слово перевертыша переводится следующим образом: буквы, стоящие до первого гласного, перемещаются до конца слова и соединяются с окончанием quot; циусquot;. Например.
a)" кот в сапогах " -- " откциус вциус апогахсциус"
b) "пример перевода" -- " имерпрциус ереводапциус"
Ответы на вопрос
Ответил Вованичикчка
0
// PascalABC.Net
var vowel: set of char = ['а', 'у', 'о', 'ы', 'и', 'э', 'я', 'ю', 'ё', 'е'];
s, substr: string;
begin
s := 'кот в сапогах';
var words := s.Split(' ');
for var i := 0 to words.length - 1 do
begin
for var j := 1 to words[i].Length do
if words[i][j] in vowel then
begin
substr := Copy(words[i], 1, j-1);
Delete(words[i], 1, j-1);
words[i] += substr;
break;
end;
words[i] += 'циус';
end;
writeln(words.JoinIntoString(' '));
end.
Новые вопросы
Химия,
2 года назад
Русский язык,
2 года назад
Литература,
7 лет назад
Физика,
8 лет назад
Химия,
8 лет назад