Информатика, вопрос задал shixmerzaev , 2 года назад

Составьте программу. Дана сумма номеров страниц книги. Определить последнюю страницу и количество листов в книге. Сумма номеров страниц 61.


7limonchiK7: а так, могу скинуть свою реализацию
Аноним: страницы 30, 31 в сумме 61, последняя страница 31, листов 16 )))
vershitelsudeb: сумма номеров страниц 61, а не номеров двух последних страниц
Аноним: не сказано же что всех номеров? ))))
Аноним: задача с не корректным условием
Аноним: например, сумма 9 - стр. 4, 5. сумма 15 - стр. 1, 2, 3, 4, 5. последние стр. одинаковы и листов тоже )))
vershitelsudeb: ну так поэтому имеется ввиду сумма всех страниц
vershitelsudeb: и тогда будет только один вариант
Аноним: да кто ж их знает что у них на уме? если 61 никак не наберешь)
vershitelsudeb: это да... видимо опечатка в сумме страниц

Ответы на вопрос

Ответил 7limonchiK7
2

var all_list, list, count, i:integer;

begin

list := 0; count:=0;

write('Введите сумму номеров страниц книги: ') ;

readln(all_list);

while all_list <> list do

begin

count := count +1;

list := list + count;

end;

writeln('Всего листов: ', count);

write('Последняя страница: ', count*2);

end.

Новые вопросы