Составте пожалуйста программу (паскале абц) и блок схему
Даны два действительных положительных числа x и y.
Тригонометрические действия над числами пронумерованы (1 - sin, 2 - cos, 3 - tg,
4 - ctg). Составить программу, которая по введенному номеру n выполняет то или
иное действие над числами x и y.
Ответы на вопрос
Ответил HRAshton
0
var
n: integer;
x, y: real;
begin
readln(n, x, y);
case n of
1: writeln('sin(', x, ') = ', sin(x), #13, 'sin(', y, ') = ', sin(y));
2: writeln('cos(', x, ') = ', cos(x), #13, 'cos(', y, ') = ', cos(y));
3: writeln('tg(', x, ') = ', tan(x), #13, 'tg(', y, ') = ', tan(y));
4: writeln('ctg(', x, ') = ', 1 / tan(x), #13, 'ctg(', y, ') = ', 1 / tan(y));
else
writeln('Null');
end;
end.
n: integer;
x, y: real;
begin
readln(n, x, y);
case n of
1: writeln('sin(', x, ') = ', sin(x), #13, 'sin(', y, ') = ', sin(y));
2: writeln('cos(', x, ') = ', cos(x), #13, 'cos(', y, ') = ', cos(y));
3: writeln('tg(', x, ') = ', tan(x), #13, 'tg(', y, ') = ', tan(y));
4: writeln('ctg(', x, ') = ', 1 / tan(x), #13, 'ctg(', y, ') = ', 1 / tan(y));
else
writeln('Null');
end;
end.
Приложения:

Новые вопросы