Информатика, вопрос задал demidkagorokhov , 6 лет назад

Составьте на языке программирования Паскаль программу для обработки массива из 15 чисел. Значения элементов массива задайте путём ввода с клавиатуры. Входные данные придумайте самостоятельно. Вычислите сумму элементов массива, не равных нулю, больших b и меньших a. Напечатайте номера элементов, которые удовлетворяют поставленному условию. Значения переменных a и b задайте самостоятельно.



Программная реализация обязательна. На проверку нужно прислать скриншот окна программы Паскаль с отображением кода программ и результата работы.

Ответы на вопрос

Ответил Papapapapapam
1

Ответ:

var m:array[1..15] of integer;

   i,a,b,s:integer;

begin

writeln('Введите "a"');

readln(a);

writeln('Введите "b"');

readln(b);

s:=0;

for i:=1 to 15 do begin

  read(m[i]);

  if (m[i]>b) and (m[i]<a) then begin

    print(i);

    s+=m[i];

  end;

end;

writeln('Сумма = ', s);

end.

Объяснение:

нужны пояснения - могу предоставить

Приложения:

demidkagorokhov: Спасибо большое
Новые вопросы