СОСТАВИТЬ В ПАСКАЛЕ .Составьте программу вычисления суммы нечетных составных делителей кратных 5 натурального числа M.
70баллов СРОЧНО
Ответы на вопрос
Ответил raf1O5
0
Код программы на языке PascalABC
program raf105;
var m,sum,i: integer;
begin
write('M = ');
readln(m);
write('Нечётные составные делители кратные пяти: ');
for i:=1 to m do
if (i mod 5 = 0) and (i <> 5) and (m mod i = 0) and (i mod 2 <> 0)
then begin sum:= sum+i; write(i,' '); end;
writeln;
writeln('Их сумма: ',sum);
end.
Результат работы программы
M = 10000
Нечётные составные делители кратные пяти: 25 125 625
Их сумма: 775
Новые вопросы
Английский язык,
2 года назад
Английский язык,
2 года назад
Алгебра,
7 лет назад
Обществознание,
7 лет назад
Математика,
9 лет назад