Составить программы для задач (в Паскале)
1) Вводится натуральное число N. Вывести все целые числа от N до 1.
Пример:
Входные данные: 5
Выходные данные: 5 4 3 2 1
2) Вводятся два целых числа A и B. Вывести все нечётные числа от A до B, включая A и B.
Пример:
Входные данные: 3 10
Выходные данные: 3 5 7 9
3) Вводятся два целых числа A и B. Вывести сумму всех чисел от A до B, включая A и B, которые заканчиваются на 7.
Пример:
Входные данные: 5 30
Выходные данные: 51
(Пояснение: 7+17+27=51)
Помогите пожалуйста ☠️
Ответы на вопрос
Ответил liliyabelova2000
0
Ответ 1:
Program zadacha;
var
i,n:integer;
begin
writeln ('Введите число: '); readln(n);
for i:=1 to n do write(n-i+1);
end.
Ответ 2:
Program zadacha;
var
i,a,b:integer;
begin
writeln ('Введите A: '); readln(a);
writeln ('Введите B: '); readln(b);
for i:=a to b do
if (i mod 2 <> 0) then writeln(i);
end.
Ответ 3:
Program zadacha;
var
i,a,b,sum:integer;
begin
writeln ('Введите A: '); readln(a);
writeln ('Введите B: '); readln(b);
for i:=a to b do
if (i mod 10 = 7) then begin sum:=sum+i; end;
writeln('Результат: ',sum);
end.
Приложения:



Новые вопросы
Английский язык,
2 года назад
Другие предметы,
2 года назад
Музыка,
7 лет назад
Алгебра,
7 лет назад
Математика,
9 лет назад