Информатика, вопрос задал dementevavik , 1 год назад

Составить программу, запрашивающую оценки за контрольные работы по информатике и физике. Если их сумма не менее 8, то на экран должен выводится комментарий «Молодец», в противном случае – «Постарайся»
Оценки по физике: 5 5 5 5 5 5 5 5 5
Оценки по информатике: 5 4 4 4 3 3


firstaftergod2501: Сколько оценок может быть?
dementevavik: В задании не указано

Ответы на вопрос

Ответил firstaftergod2501
1

Ответ:

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL, "Russian");

   int GradesInformatics,  GradesPhysikc;

   cout << "Введите количество оценок по информатике" <<endl;

   cin >> GradesInformatics;

   cout << "Введите количество оценок по физике" << endl;

   cin>> GradesPhysikc;

   int* Informatics = new int[GradesInformatics];

   int* Physicks = new int[GradesPhysikc];

   int Tmp = 0;

    cout << "Введите оценки по информатике" <<endl;

   for (int i = 0; i < GradesInformatics; ++i) {

       cin >> Informatics[i];

   }

   cout << "Введите оценки по Физике" <<endl;

   for (int i = 0; i < GradesPhysikc; ++i) {

       cin >> Physicks[i];

   }

   for (int i = 0; i < GradesInformatics + GradesPhysikc; ++i) {

       Tmp = Tmp + Informatics[i] + Physicks[i];

   }

   if (Tmp > 8) {

       cout << "Молодец " << endl;

   }

   else {

       cout << "Постарайся " << endl;

   }

   delete[] Informatics;

   delete[] Physicks;

}

Объяснение:

Код на с++

Так как в задании не указано,сколько всего оценок может быть,то спрашиваем это в рантайме у пользователя. Затем получаем эти оценки при помощи двух циклов for. Потом складываем всё,что получилось в tmp и выводим ответ

Новые вопросы