Составить программу заполняя масива из 100 чисел случаиними значениями -20 до 20 . Почитать количество отрецательних и положительних чисел . помогитеееееееееееееееееееееее
Ответы на вопрос
Ответил Аноним
0
Var A:array[1..100] of integer;
i,Ko,Kp:integer;
Begin
Ko:=0;
Kp:=0;
Write('Исходный массив: ');
For i:= 1 to 100 do
Begin
A[i]:=random(41)-20;
Write(A[i],' ');
if A[i]<0 then Ko:=Ko+1
else if A[i]>0 then Kp:=Kp+1;
End;
WriteLn;
WriteLn('Количество отрицательных: ',Ko);
WriteLn('Количество положительных: ',Kp);
End.
i,Ko,Kp:integer;
Begin
Ko:=0;
Kp:=0;
Write('Исходный массив: ');
For i:= 1 to 100 do
Begin
A[i]:=random(41)-20;
Write(A[i],' ');
if A[i]<0 then Ko:=Ko+1
else if A[i]>0 then Kp:=Kp+1;
End;
WriteLn;
WriteLn('Количество отрицательных: ',Ko);
WriteLn('Количество положительных: ',Kp);
End.
Ответил Аноним
0
Главное, что эта прога на Турбо Паскале пойдёт, а значит и на любом другом
Новые вопросы