Информатика, вопрос задал chyvirlik228 , 2 года назад

Составить программу заполнения массива по формуле A[ i ]=i²*(i+1) Подсчитать произведение нечетных элементов

Ответы на вопрос

Ответил alchetorn
1

Ответ:

Нужно на Паскале?

program ex;

const n = 5;

var a:array[1..n] of integer;

i:byte; product:longint;

begin

product:=1;

for i:=1 to n do a[i]:=sqr(i)*(i+1);

writeln('Массив: ');

for i:=1 to n do writeln('a[',i,'] = ',a[i]);

for i:=1 to n do if i mod 2 = 1 then product:=product*a[i];

writeln('Произведение нечётных элементов = ',product);

end.

Ответил p15
1

Ответ:

n=int(input())

S=1

A=[i*i*(i+1) for i in range(n+1)]

for i in range(1,n+1,2):

   S*=A[i]

print(S)

Объяснение:

Предлагаю на пайтоне. Значительно проще.

Новые вопросы