Информатика, вопрос задал danyayurkov97 , 1 год назад

составить программу задающую последовательность чисел кратных 3 из 77 элементов и находящую сумму всех чисел последовательности.щ

Ответы на вопрос

Ответил gfhjkmgfhjkm20
0

Ответ:

var a,k,s:integer;

begin

a:=3;

k:=1;

s:=0;

write('Последовательность ');

repeat

write(a,' ');

s:=s+a;

a:=a+3;

k:=k+1

until k>77;

writeln;

writeln('Сумма ',s)

end.

Ответил BobbyFresnel
0

===== PascalABC.NET =====

begin

 SeqGen(77, i -> 3 * i, 1).Sum.Println

end.

Объяснение:

Поскольку не сказано, от какого числа последовательность начинается, договоримся, что это последовательность натуральных чисел и первым в ней является число 3. Фактически, это арифметическая прогрессия с разностью d = 3, содержащая 77 членов. Формула нахождения суммы такой последовательности общеизвестна, и создавать программу тут абсолютно нет надобности. Но уж настолько бедна фантазия авторов заданий, что они не в состоянии дать задачу, где действительно требуется программирование. Будем считать, что это задание демонстрирует случай, когда программы писать не нужно.

Итак сумма S = ( 2 · 3 + 3 · ( 77 - 1 ) ) · 77 / 2 = 9009.

Приложения:
Новые вопросы