Составить программу, выводящую значение TRUE или FALSE. Шахматный король за один ход может переместиться с одного заданного поля на другое (каждое после задано двумя координатами - целыми числами от 1 до 8). На паскале
Ответы на вопрос
Ответил FANTSCR1N
0
Program KING;
Var x,y,x1,y1: integer;
Begin
writeln('Введите координаты расположения Короля:');
write('Коор. x - '); readln(x);
write('Коор. y - '); readln(y);
writeln('Введите координаты клетки хода:');
write('Коор. x - '); readln(x1);
write('Коор. y - '); readln(y1);
if ((x = x1) and (y = y1))
then writeln('FALSE')
else if (abs(x1 - x) < 2)
then if (abs(y1 - y) < 2)
then writeln('TRUE')
else writeln('FALSE')
else writeln('FALSE');
End.
Ответил Аноним
0
Весь набор этих условий и выводов можно заменить единственным оператором
Ответил Аноним
0
Writeln(((x<>x1) or (y<>y1)) and (Abs(x-x1)<2) and (Abs(y-y1)<2));
Новые вопросы
История,
2 года назад
Физика,
2 года назад
Геометрия,
8 лет назад
Физика,
8 лет назад
Математика,
9 лет назад