Информатика, вопрос задал xrennn , 1 год назад

Составить программу вывода на экран суммы квадратов нечетных чисел из диапазона от 4 до 17. ​


dejnekodasha: какой язык программирования?
xrennn: паскаль абс

Ответы на вопрос

Ответил Dilorf
1

Ответ:

program 123;

var

 i, sum: integer;

begin

 sum := 0;

 for i := 5 to 17 step 2 do

 begin

   sum := sum + i*i;

 end;

 writeln('Сумма квадратов нечетных чисел в диапазоне от 4 до 17 равна: ', sum);

end.

Объявляется переменная sum для хранения суммы квадратов нечетных чисел, затем используется цикл for, чтобы перебрать все нечетные числа в диапазоне от 4 до 17 с шагом 2. Каждое число возводится в квадрат и добавляется к переменной sum. Наконец, результат выводится на экран при помощи writeln.

Новые вопросы