составить программу
высота сосны в начале года 1.8 м, а к концу года она увеличилась на 15%. какая будет высота через "n" лет, если ее прирост за каждый следующий год= 90 % от прироста предыдущегоспасибо
Ответы на вопрос
Ответил oxxid
0
program first;
var a,b:real; n:integer;
begin
readln(n);
if n=0 then begin
writeln('Сосна почти не выросла за этот промежуток времени');
exit;
a:=1,8;
b:=(1,8*15)/100;
for i:=1 to n-1 do
b:=b+((b*90)/100);
writeln('Висота сосны через ',n,' лет равна', a+b);
end.
var a,b:real; n:integer;
begin
readln(n);
if n=0 then begin
writeln('Сосна почти не выросла за этот промежуток времени');
exit;
a:=1,8;
b:=(1,8*15)/100;
for i:=1 to n-1 do
b:=b+((b*90)/100);
writeln('Висота сосны через ',n,' лет равна', a+b);
end.
Ответил preceptor
0
Проверил, нет разницы, писать ли 1 год или 0, результат один. Проверьте ваш код :)
Ответил preceptor
0
Написано на Pascal:
Program Sosna;
Var a, b: Real;
n, i: Integer;
Begin
a := 1.8;
Write('n = ');
ReadLn(n);
b := a * 0.15;
a := a + b;
For i := 1 To n Do
Begin
b := b * 0.9;
a := a + b;
End;
WriteLn('Высота сосны через ', n,' лет будет ', a:10:2, ' м.');
ReadLn;
End.
Program Sosna;
Var a, b: Real;
n, i: Integer;
Begin
a := 1.8;
Write('n = ');
ReadLn(n);
b := a * 0.15;
a := a + b;
For i := 1 To n Do
Begin
b := b * 0.9;
a := a + b;
End;
WriteLn('Высота сосны через ', n,' лет будет ', a:10:2, ' м.');
ReadLn;
End.
Новые вопросы
Английский язык,
2 года назад
Геометрия,
10 лет назад
Математика,
10 лет назад
Обществознание,
10 лет назад