Составить программу, вычисляющую сумму всех положительных элементов массива а[5][5] и произведение отрицательных С++ Без функции.
Ответы на вопрос
Відповідь:
#include <iostream>
#include <cstdlib>
#include <time.h>
using namespace std;
const int n = 5, m = 5;
int main(){
srand(time(NULL));
setlocale(LC_ALL, "Rus");
int sum = 0, pr = 1;
int **arr = new int *[n];
for (int i = 0; i < n; i++)
arr[i]=new int[m];
cout << "Матрица порядка " << n << "x" << m << ":" << endl;
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
arr[i][j] = rand() % 109 + (-37);
}
}
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
cout << arr[i][j] << "\t";
}
cout << endl;
}
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
if(arr[i][j] > 0){
sum+= arr[i][j];
}
if(arr[i][j] < 0){
pr *= arr[i][j];
}
}
}
cout << "\nСумма положительных елементов массива = " << sum << endl;
cout << "Произведение отрицательных елементов массива = " << pr << endl;
for (int i = 0; i < n; i++)
delete[]arr[i];
delete[]arr;
return 0;
}