составить программу вычисляющую площадь произвольного треугольника со сторонами a b c в программе pascal
Ответы на вопрос
Ответил ManulTheLiar
1
program prog;
uses crt;
var
a,b,c,s,p:real;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
write('c = ');
readln(c);
if (a>0) and (b>0) and (c>0) then
begin
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('S = ',s:0:3);
end;
end.
uses crt;
var
a,b,c,s,p:real;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
write('c = ');
readln(c);
if (a>0) and (b>0) and (c>0) then
begin
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('S = ',s:0:3);
end;
end.
Новые вопросы
Окружающий мир,
2 года назад
Английский язык,
2 года назад
Математика,
2 года назад
Математика,
7 лет назад