Информатика, вопрос задал balamut6 , 8 лет назад

составить программу вычисления значений функции y. ( 2,3) Delphi или C++ Bilder.

Приложения:

Ответы на вопрос

Ответил Aillianna
0
function y(x: real): real;
begin
    if x < -1 then
        y := 1 - 2 * x
    else if x <= 2 then
        y := 2 + x * x
    else
        y := abs(2 * x * x) + 1;
end;

function z(x, y: real): real;
begin
    z := 2 * x / (48 - y * y) + 15 * sin(x);
end;

var
    x: integer;

begin
    for x := -10 to 10 do
        writeln('x=',x, ' y=', y(x), ' z=', z(x, y(x)));
end.
Новые вопросы