Информатика, вопрос задал 92Shaarawy921 , 9 лет назад

Составить программу вычисления,
W = B +  frac{A}{C+1}
A - сумма положительных элементов массива;
B – номер наименьшего элемента массива;
C - количество элементов массива кратных пяти.
Полученные значения элементов А,B,C,W вывести на печать.(Паскаль)

Ответы на вопрос

Ответил NaaMan
0
Специально для вас выловил ошибки, находящиеся в предыдущем решении. Кому-то не повезло :(

//PascalABC
var
    S : array[1..10000] of integer;
    A, B, C, i, N, min : integer;
    W : real;
begin
    write('Укажите размер массива > ');
    readln(N);
    write('Вводите элементы массива > ');
    for i := 1 to N do
        readln(S[i]);
       
    A := 0;
    min := S[1];
    C := 0;
    for i := 1 to N do begin
        if S[i] > 0 then A := A + S[i];
        if S[i] < min then begin
            B := i;
            min := S[i];
        end;
        if S[i] mod 5 = 0 then C := C + 1;
    end;
    W := B + A / (C + 1);
    writeln('Сумма элементов ', A);
    writeln('Номер минимального эл-та ', B);
    writeln('Количество кратных пяти ', C);
    writeln('Параметр W ', W);
end.

Приложения:
Ответил Аноним
0
А Вы представьте, что надо и картинку смотреть, и набирать. Все это в разных программах и разных окнах.
Ответил NaaMan
0
Да, я этим пользуюсь :) Я ещё не отладил, свое общение здесь, так что простите великодушно :)))
Ответил NaaMan
0
Иногда бывает быстрее ручкой набросать на листке бумаги, сфотографировать и отослать, чем то же самое писать в неудобном окне веб-интерфейса.
Ответил Аноним
0
Конечно, так тоже бывает.
Новые вопросы