Составить программу вычисления в массиве a, содержащего n элементов, произведения отрицательных чисел, кратных трем.
Ответы на вопрос
Ответил yangel2004
0
var n,i,p:longint;a:array[1..1000000] of longint;
begin
readln(n);
for i:=1 to n do
read(a[i]);
p:=1;
for i:=1 to n do
if (a[i]<0) and(a[i] mod 3 =0) then p:=p*a[i];
writeln(p);
End.
begin
readln(n);
for i:=1 to n do
read(a[i]);
p:=1;
for i:=1 to n do
if (a[i]<0) and(a[i] mod 3 =0) then p:=p*a[i];
writeln(p);
End.
Новые вопросы
Математика,
2 года назад
Математика,
8 лет назад