Информатика, вопрос задал melllipton , 7 лет назад

составить программу вычисления суммы всех натуральных чисел, меньших М, в записи которых нет парных цифр. Использовать функцию определения количества парных цифр в числе.

Язык c++

Ответы на вопрос

Ответил Светлана008
0

#include <iostream>

using namespace std;

int sum( int n  ){

   int k = 0;

   int t = n;

   while ( t > 0 )

   {

       if ( ( t % 10 ) % 2 == 0 )

           k++;

       t /= 10;

   }

   return k;

}

int main()

{

   int  M,S,p;

   cin  >> M;

   S = 0;

   for ( int i = 1; i < M; i++ ){

    p = sum(i);

       if ( p == 0 ) {

           S = S + i;

       }

   }

   cout << S;

   return 0;

}

Новые вопросы