Информатика, вопрос задал khelga14 , 7 лет назад

Составить программу вычисления суммы первых 10 натуральных чисел. (Программу написать двумя способами: 1.цикл с предусловием while, 2.цикл с постусловием repeat) ​

Ответы на вопрос

Ответил leonidopuss
0

1.

begin

var a,b:integer;

a:=1;

b:=0;

while a<=10 do begin

b:=b+a;

a+=1;

end;

writeln(b);

end.

2.

begin

var a,b:integer;

a:=1;

b:=0;

repeat

b:=b+a;

a+=1;

until a > 10;

writeln(b);

end.

Новые вопросы