Информатика, вопрос задал Pr1ttyCat , 10 лет назад

составить программу вычисления суммы чётных чисел и произведение нечётных чисел от 1 до 10. (через паскаль)

Ответы на вопрос

Ответил ilyaKZ
0

Паскаль.

 

 

program jjj;

var a: array [1..10] of integer; i,summa,proizv:integer;

begin

for i:=1 to 10 do begin

   Writeln('напишите элемент массива номер ',i); read(a[i]);

                        end;

For i:=1 to 10 do begin

                              if a[i] mod 2=0 then summa:=summa+a[i] else

                                if (a[i]<=10) and (a[i]>=1) then  proizv:=proizv*a[i];

                         end;

Writeln(summa,'   ',proizv); readln;

end.

 

Жирным - это то, что я добавил)

Новые вопросы