Информатика, вопрос задал dasha1894 , 10 лет назад

составить программу вычисления средней температуры за месяц

Ответы на вопрос

Ответил assechka
0

Program z;

uses crt;

var

 s,x,i:real;

begin

clrsc;

x:=0

for i:=1 to 30 do begin

                     writeln('введите температуру');

readln(x);

sr:=sr+x;

end;

y:=sr/30;

writeln('ср темп равна',y);

readln;

end. 

Ответил sansanic
0

const

  n = 30; //n - количество дней в месяце

var

  t: array [1..n] of real;

  i: integer;

  s: real;

begin

  s:= 0;

  for i:= 1 to n do 

  begin

    writeln('Введите температуру ', i, ' дня');

    readln(t[i]);

    s:= s + t[i];

  end;

  writeln('Средняя температура за месяц: ', s / n);

end.

    

Новые вопросы