Составить программу вычисления следующих величин. Элементы списка (массива) определяются по формуле a[i] = p[i] – 64; где p[i+1] = (p[i] * 67 + 11) % 128. p[0] равно n – 3, количество элементов в списке равняется 50.
Сумма элементов массива a, значения которых четны.
Ответы на вопрос
Ответил ZyMaa
0
Ответ:
104
Объяснение:
Не совсем понятно что такое n - 3, если предположить что n - кол. элементов в списке, то программа на с++ вычисляющая ответ будет выглядеть так:
#include <bits/stdc++.h>
#define N 55
using namespace std;
int main()
{
int a[N], p[N];
p[0] = 47;
for(int i = 0; i < 50; i++)
{
p[i + 1] = (p[i] * 67 + 11) % 128;
}
int sum_even = 0;
for(int i = 0; i < 50; i++)
{
a[i] = p[i] - 64;
if(a[i] % 2 == 0) sum_even += a[i];
}
cout << sum_even;
return 0;
}
Выводит 104 :P
Новые вопросы
Математика,
1 год назад
Английский язык,
1 год назад
Английский язык,
1 год назад
Русский язык,
6 лет назад
Алгебра,
6 лет назад