Информатика, вопрос задал stepanovsandr , 1 год назад

Составить программу вычисления количества положительных, кратных 5 элементов массива, состоящего из 25 целых чисел

Ответы на вопрос

Ответил gfhjkmgfhjkm20
1

Ответ:

var a:array [1..25] of integer;

i,k:integer;

begin

write('Массив ');

for i:=1 to 25 do

begin

a[i]:=random(31)-15;

write(a[i]:5);

if (a[i] mod 5 = 0) and (a[i]>0) then k:=k+1

end;

writeln;

write('Количество положительных, кратных 5, элементов массива равно ',k)

end.

Ответил BobbyFresnel
0

===== PascalABC.NET =====

begin

 var a := ArrRandom(25, -99, 99);

 a.Println;

 a.Count(p -> (p > 0) and (p mod 5 = 0)).Println

end.

Приложения:
Новые вопросы