Информатика, вопрос задал merlin2 , 8 лет назад

Составить программу вычисления и печати суммы всех членов последовательности, меньших 0.8:
S=1/3+2/4+3/5.....+i/(i+2)

Ответы на вопрос

Ответил srzontmp
0
// i/(i+2) = 0.8  -> 0.2i=1.6 -> i=8 
var i: integer;
     s: real;
begin
  s:=0; i:=1;
  repeat
    s:=s+i/(i+2);
    i:=i+1;
  until i=8;
  writeln('сумма ряда: ',s);
end.


Новые вопросы