Составить программу вычисления функции на паскале АВС.NET на заданных промежутках и с заданным шагом h.

x∈[0,π]
h=π/8
Используя var, const, writeln и т.д.
Ответы на вопрос
Ответил LRSM
0
Ответ:
- begin
- var f: real -> real := x -> (sin(x)+cos(x))/(1+sqr(x));
- PartitionPoints(0, Pi, 8).Tabulate(x -> f(x))
- .ForEach(x->writeln('x:',x.Item1:7:3,' y:',x.Item2:7:3));
- end.
или без косметики:
- begin
- PartitionPoints(0,Pi,8).Tabulate(x->(sin(x)+cos(x))/(1+sqr(x))).Print
- end.
Примеры работ:
Приложения:


Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
История,
2 года назад
Химия,
2 года назад
Химия,
8 лет назад