Информатика, вопрос задал kaemelyanowa , 7 лет назад

Составить программу, вставляющую перед каждой цифрой 0 в исходной строке слово "zero"

Ответы на вопрос

Ответил liliyabelova2000
0

Ответ:

program zadacha;

var

a:array[1..100] of integer;

i,n:integer;

begin

 writeln('Введите размерность массива:');readln(n);

  write ('Введите элементы массива:');

  for i := 1 to n do read (a[i]);;

   writeln ('Результаты:');

  for i:=1 to n do

  if (a[i]=0) then write('zero ',a[i],', ')

  else write (a[i],', ');

end.

Проверка компилятора в скриншоте.

Приложения:
Новые вопросы