Информатика, вопрос задал love280399 , 9 лет назад

Составить программу в среде Turbo Pascal для решения следующей задачи: «Вычислить все значения и найти количество элементов больших 10, для у=а(х+1), если а=2, шаг=1 и х€[-5;15]».

Ответы на вопрос

Ответил therealcf2014
0
const
  a=2;
  step=1;
  x0=-5;
  x1=15;

var
  i, count: integer;

function y(x: integer): integer;
begin
  y:=a*(x+1);
end;

begin
  for i:=x0 to x1 do
  begin
    writeln('f(', i, ') = ', y(i));
    if y(i)>10 then inc(count)
  end;
  writeln('Количество f(x)>10: ', count)
end.
Новые вопросы