Информатика, вопрос задал PandaLo14 , 9 лет назад

Составить программу в Паскале, выясняющую количество элементов в заданном массиве, отличающихся от минимального на 5.
Очень прошу, помогите, срочно!

Ответы на вопрос

Ответил 068419084
0
program p26;
 type lol=array[1..100] of integer;
var min,i,n,k:integer;
t:lol;
begin
write('количество элементов?');
readln(n);
write('элементы');
for i:=1 to n do
readln(t[i]);
min:=9999;
for i:=1 to n do
if(min>t[i]) then min:=t[i];
for i:=1 to n doif(t[i]>min+5) or (t[i]<min-5) then k:=k+1;
write('количество элементов отличающихся от минимального на 5=',k);
end.
Новые вопросы