Информатика, вопрос задал maria97 , 10 лет назад

составить программу в паскале!!! ПОЖАЛУЙСТА!!! СРОЧНО!!! 9 класс!!! На ввод в программу натурального числа из диапазона [1, 25] программа выводит это число и согласованное с ним слово «книга». Например, на ввод числа 1 программа выводит «1 книга», на ввод числа 2 — «2 книги» и т. д.

Ответы на вопрос

Ответил Tlalok
0

var

  count:integer;

begin

  write('Введите количество книг '); readln(count);

  case count div 10 of

    1: writeln(count, ' книг');

    else

      case count mod 10 of

        0, 5..9: writeln(count, ' книг');

        1: writeln(count, ' книга');

        2..4: writeln(count, ' книги');

      end;

  end;

end.

Новые вопросы