составить программу в паскале! пожалуйста!!! СРОЧНО! 9 класс! Написать программу, которая на ввод времени суток выводит соответствующее пожелание доброго утра, доброго дня, доброго вечера или спокойной ночи.
Ответы на вопрос
var
time: 0..23;
begin
writeln('Введите текущее время в часах');
readln(time);
if time in [0..6] then writeln('Спокойной ночи!');
if time in [7..12] then writeln('Доброго утра!');
if time in [13..18] then writeln('Доброго дня!');
if time in [19..23] then writeln('Доброго вечера!');
end.
Пояснение: в этой программе используются множества. Если время в часах входит в множество чисел, указанных в квадратных скобках, то программа пишет соответствующее сообщение. Например: if time in [0..6] означает: если введенное время входит в промежуток от 0 до 6.
var
hour:integer;
begin
write('Который час? '); readln(hour);
case hour of
6..11: writeln('Доброе утро');
12..15:writeln('Добрый день');
16..21: writeln('Добпый вечер');
22..24, 0..5: writeln('Доброй ночи');
else
writeln('В сутках только 24 часа');
end;
end.
//через if
var Hour:integer;
begin
writeln('Введите время');
readln(Hour) ;
if Hour <= 12 then
begin
writeln('Добрго утра');
end;
if (Hour > 12) and (Hour < 20) then
begin
writeln('Доброго дня');
end;
if (Hour >= 20) and (Hour <= 24) then
begin
writeln('Добрый вечер');
end;
if Hour > 24 then
begin
writeln('Не многовато часиков то ?');
end;
end.