Информатика, вопрос задал Mashasuhankva , 8 лет назад

Составить программу в Паскале
- на вход программе подаются данные датчика температуры. Температура изменяется 24 раза в стуки. Температура измеряется от 19 до 23 градусов, надо найти количество измерений в которых температура была 20 градусов Не толко ответ, но и программу расписать, буду благодарна

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1345 от 24.11.2016
// Внимание! Если программа не работает, обновите её версию!
begin
  var t:=ArrRandom(24,19,23); t.Println;
  Writeln('Температура +20 была ',t.Where(x->x=20).Count,' раз(а)')
end.

Пример
23 22 22 23 20 19 19 21 19 20 22 20 21 22 20 19 22 22 21 20 21 21 23 23
Температура +20 была 5 раз(а)

Новые вопросы