Информатика, вопрос задал skvidvard00 , 2 года назад

Составить программу в паскале которая ,находит среднее арифметическое натуральных чисел, меньших 200 и кратных 7.

Ответы на вопрос

Ответил Omikami
0

Ответ:

begin

 Range(7, 200, 7).Average().Print();

end.

//PascalABC.NET 3.5.X

Ответил LRSM
0

Ответ:

  • begin
  • (1..199).Where(x -> x mod 7 = 0).Average.Print
  • end.

или

  • var i,s,n: integer;
  • begin
  • while i+7<200 do
  • begin
  • i := i + 7;
  • s := s + i;
  • n := n + 1;
  • end;
  • write(s/n);
  • end.

Пример работы:

Приложения:

skvidvard00: а можешь из паскаля скопировать , без этих точек . 2 вариант нужен
skvidvard00: просто мне вот такой ответ выдает прога 1.0150000000000000E+002
LRSM: "без этих точек" -- они не копируются при копировании текста.
"1.0150000000000000E+002" -- то же самое, что и 101.5
Новые вопросы