Информатика, вопрос задал Gyry152001Masha , 7 лет назад

Составить программу в паскале для сравнения периметров треугольника равностороннего и квадрата

Ответы на вопрос

Ответил Sadstorm
0

(Смотрите ответ ниже, он лучше)

var a,b,c : integer;

begin

writeln('Введите сторону равностороннего треугольника и квадрата');

readln(a,b);

c:=a*3;

a:=c;

c:=b*4;

b:=c;

if a>b then writeln('Периметр треугольника больше периметра квадрата');

if a<b then writeln('Периметр квадрата больше чем периметр треугольника');

if a=b then writeln('Периметры равны');

end.

(поставьте одну звезду, пожалуйста, надеюсь, это удалят)

Ответил Аноним
0
Значение периметров в вопросе выводить не просили. Просили сравнить.
Ответил Sadstorm
0
я тупой, не увидел
Ответил Sadstorm
0
сердечно извеняюсь
Ответил Аноним
0
Поправить же несложно)))
Ответил Аноним
0
Кто же и на каком основании удалит программу, если она правильно работает? )))
Ответил Аноним
0

// PascalABC.NET 3.4.2, сборка 1782 от 01.09.2018

// Внимание! Если программа не работает, обновите версию!

begin

 var (a, b) := ReadReal2('Введите сторону треугольника и квадрата:');

 case Sign(3 * a - 4 * b) of

   -1: Println('Периметр квадрата больше');

   0: Println('Периметры равны');

   1: Println('Периметр треугольника больше')

 end

end.

Приложения:
Новые вопросы