Информатика, вопрос задал maks567898 , 9 лет назад

Составить программу в паскале для решения квадратного уравнения ax^2+bx+c=0

Ответы на вопрос

Ответил Аноним
0
Var
  a,b,c,d:real;
Begin
  write('Введите коэффициенты уравнения (a, b, c): ');
  Readln(a,b,c);
  d:=sqr(b)-4*a*c;
  if d>0 then Begin
    write('X1 = ',((-b)+sqrt(d))/(2*a),' | ');
    write('X2 = ',((-b)-sqrt(d))/(2*a));
  end else if d = 0 then write('X = ',(-b)/(2*a)) else write('Корней нет');
End. 
Новые вопросы