Составить программу в паскале.Дан массив целых чисел, состоящий из 13 элементов. Заполнить его с клавиатуры. Найти: сумму элементов, имеющих нечетные индексы.
Ответы на вопрос
Ответил averutin
0
program boo;
uses crt;
var
b : array[1..13] of integer;
s : integer;
i : byte;
begin
writeln('Заполните массив:');
for i := 1 to 13 do
readln(b[i]);
clrscr;
s := 0;
for i:=1 to 13 do begin
write(b[i], ' ');
if (i mod 2 <> 0) then s := s + b[i];
end;
writeln;
writeln('Сумма нечётных элементов равна ', s);
end.
uses crt;
var
b : array[1..13] of integer;
s : integer;
i : byte;
begin
writeln('Заполните массив:');
for i := 1 to 13 do
readln(b[i]);
clrscr;
s := 0;
for i:=1 to 13 do begin
write(b[i], ' ');
if (i mod 2 <> 0) then s := s + b[i];
end;
writeln;
writeln('Сумма нечётных элементов равна ', s);
end.
Новые вопросы