Информатика, вопрос задал esketit123 , 8 лет назад

Составить программу в паскале, что бы из слова "Победа" поочередно убирались буквы, примерно так:
Победа
Обеда
Беда
еда
да
а

Ответы на вопрос

Ответил pacixor
0
//Pascal
var S: string;
begin
S := 'Победа';
while Length(S) <> 0 do
begin
  writeln(S);
  delete(S,1,1);
end;
end.
Приложения:
Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:='Победа';
  for var i:=1 to s.Length do Writeln(s[i:])
end.

Результат
Победа
обеда
беда
еда
да
а
Приложения:
Новые вопросы