Информатика, вопрос задал maria97 , 10 лет назад

составить программу в паскале! 9 класс! СРОЧНО!!! пожалуйста!!! без всяких div и mod. Год является високосным, если его номер кратен 4. Из кратных 100 високосными являются лишь те года, которые кратны также 400 (например, 1700, 1800 и 1900 — не високосные года, 2000 — високосный). Дано натуральное число n. Определить, является ли високосным год с таким номером.

Ответы на вопрос

Ответил Slider808
0

programm p;

var n:integer;

begin

readln(n);

if n/4=int(n/4) then

begin

if (n/100=int(n/100))and(n/400<>int(n/400)) then

writeln('Не високосный') else

writeln('Високосный';

end

else writeln('Не високосный')

 

end;

Новые вопросы