Информатика, вопрос задал krusher77 , 8 лет назад

Составить программу в Паскале
10 абитуриентов сдали экзамены (максимальная сумма баллов за три экзамена 300). Посчитать проходной балл, если известно, что он составляет 80% от среднего балла. Посчитать количество зачисленных и вывести номера зачисленных абитуриентов.

Ответы на вопрос

Ответил Xterric
0
const n=10; m=3;
var 
a:array[1..n,1..m] of integer;
i,j,s,k:integer; p:real;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do
  begin
   a[i,j]:=random(81)+20;
   write(a[i,j]:4);
  end;
  writeln;
 end;
s:=0;
for i:=1 to n do
 for j:=1 to m do s:=s+a[i,j];
p:=s/n*0.8;
writeln('p = ',p:5:2);
writeln('Зачислены:');
k:=0;
for i:=1 to n do
 begin
 s:=0;
 for j:=1 to m do s:=s+a[i,j];
 if s>=p then begin write(i,' '); k:=k+1; end;
 end;
writeln;
writeln('k = ',k);
end.
Новые вопросы