Составить программу в Паскаль: Ученик в первый день выучил Х английских слов. В каждый следующий день он выучивал на К слов больше, чем в предыдущий. Сколько английских слов он будет знать в N-й день занятий?
Ответы на вопрос
Ответил petyaGavrikov
0
var x,k,n,s,i:integer;
begin
writeln('x, k, n:');
readln(x,k,n);
s:=x;
for i:=2 to n do
begin
x:=x+k;
s:=s+x;
end;
writeln('s = ',s);
end.
Пример:
x, k, n:
10 2 5
s = 70
begin
writeln('x, k, n:');
readln(x,k,n);
s:=x;
for i:=2 to n do
begin
x:=x+k;
s:=s+x;
end;
writeln('s = ',s);
end.
Пример:
x, k, n:
10 2 5
s = 70
Новые вопросы
Информатика,
2 года назад
Математика,
2 года назад
Информатика,
8 лет назад
Математика,
9 лет назад
Математика,
9 лет назад